project.json dosyanız içerisinde (eğer Asp.net Core / Dotnet Core'un yeni sürümünü kullanıyorsanız.) frameworks bölümünde dnxcore50 dikkatinizi çekmiştir muhtemelen.

MongoDB'nin mevcut sürümü henüz dnxcore50 framework desteği sunmadığından dolayı böyle bir hata ile karşılaşıyoruz. Bunun hızlı bir çözümü var elbet.

dnxcore50 'ı frameworks bölümünden sildiğimizde problemimiz giderilmiş oluyor. Haliyle project.json dosyanızın framework bölümü şu hali alıyor;

"frameworks": { "dnx451": {} }

Fakat bunu yaptığımızda dnxcore50 ıda kendi projemizden dışarı atmış oluyoruz bir bakıma. MongoDB tarafındaki arkadaşlarımız Asp.net Core RC2 çıktığında (ki bu 2016 Q3 bulacak denilene göre) versiyonlarını upgrade edip destek vereceklerini söylemişler fakat şu anda yok. Eğer projelerinizde MongoDB kullanacaksanız bir müddet böyle devam etmeniz gerekiyor.

Happy Coding!

Selemetle ^^